博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
The Number of set-hdu-3006
阅读量:5251 次
发布时间:2019-06-14

本文共 1498 字,大约阅读时间需要 4 分钟。

The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 987    Accepted Submission(s): 617

Problem Description

Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.

 

 

Input

There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.

 

 

Output

For each case,the output contain only one integer,the number of the different sets you get.

 

 

Sample Input

4 4

1 1

1 2

1 3

1 4

2 4

3 1 2 3

4 1 2 3 4

 

 

Sample Output

15

2

题目大意: 求给定的几个集合,能合并成多少集合,不能重复,不能删除集合中的元素。

解题思路:

1、  用二进制标记集合,如集合 1 2 3 被标记为 0111。集合1 3 4 则被标记为 1101;

2、  所以求集合的并集,就是把被标记的进行或(|)运算。并把值记录下来。

3、  查看总共有多少被记录下来的值,即有多少集合。

 

程序代码:

#include<stdio.h>

#include<string.h>

int main()

{

    int n,m,k,t,i,j,b;

    int a[1<<15];                         //定义数组,二进制的数刚好15位

    while(scanf("%d %d",&n,&m)!=EOF)

    {

      j=0;

      memset(a,0,sizeof(a));

      while(n--)

       {

         b=0;

         scanf("%d",&k);

         while(k--)

          {

            scanf("%d",&t);

            b=b|(1<<(t-1));                //标记每个集合

          }

          a[b]=1;                        // 把被标记的数 记为真值1

          for(i=0;i<=(1<<14);i++)

           {

             if(a[i])

             a[i|b]=1;                   // 把被标记的 刚刚标记的集合 进行或运算。

           }

       }

      

       for(i=0;i<=(1<<14);i++)

       {

        if(a[i])

        j++;                      // 查看被标记的总数。

       }

       printf("%d\n",j);

    }

    return 0; 

}

转载于:https://www.cnblogs.com/zhouhongweihpu/p/3233114.html

你可能感兴趣的文章
Windows 环境下基于 Redis 的 Celery 任务调度模块的实现
查看>>
趣谈Java变量的可见性问题
查看>>
C# 强制关闭当前程序进程(完全Kill掉不留痕迹)
查看>>
ssm框架之将数据库的数据导入导出为excel文件
查看>>
语音识别中的MFCC的提取原理和MATLAB实现
查看>>
验证组件FluentValidation的使用示例
查看>>
0320-学习进度条
查看>>
解决windows系统的oracle数据库不能启动ora-00119和ora-00130的问题
查看>>
ip相关问题解答
查看>>
MetaWeblog API Test
查看>>
反弹SHELL
查看>>
关闭Chrome浏览器的自动更新和升级提示
查看>>
移动、尺寸改变
查看>>
缓存三大问题
查看>>
poj2255Tree Recovery【二叉树重构】
查看>>
tcpcopy 流量复制工具
查看>>
vue和react的区别
查看>>
第十一次作业
查看>>
负载均衡策略
查看>>
数据库建立索引加快查询
查看>>